> Heh.... I'm sure we all are. The group I'm working with is waiting > for 3.0 to really get started coding, as I've heard some of you are. > I'm sure Jeremy will get it out as soon as he can... He does pretty > nice work, so even if it's late I'll be glad just to have it. ;) > Hard to rush a free product. I wish everyone was as understanding. :) A couple of weeks ago, I predicted Circle 3.0 would be late and apparently I was right. :) I'm sorry for the delay, and I know a lot of you are waiting for Circle 3.0 in order to start coding. I'm trying hard to get the MUD out as quickly as is reasonably possible, but I really don't want to release a half-baked product or something buggy. I'd rather the MUD be a week late now than to have to weal with weeks of bug reports later. I'll estimate the release should be around Feb 15 or so. There will be a beta-Circle 3.0 running for a few days at the least before the actual code release. For old times sake, I may even run it on circle.cs.jhu.edu. :) I will encourage as many people as possible to play and report bugs; I'll probably also make 'olc' a level 1 command so that anyone who wants to can test the OLC system (either that, or allow anyone to be promoted to level 31 who wants to be.) Also, although it's unlike me to do so, I'll probably be releasing the beta 3.0 code to one or two people before the full release, so that they can check for any bugs I may have missed. ObPlug: So, to sum up, Circle 3.0 will be the most feature-packed, hyper-efficient, bug-free, memory-saving, fun-loving, butt-kickin' MUD on the face of the planet. :) To people who just HAVE to start coding right NOW: you can. The code for command under Circle 3 will be 100% compatible with the code under Circle 2.2. So, if you write a cool new "do_something" command now, you'll be able to cut it out and paste it right into Circle 3.0 when it comes out. Spec-procs will be almost completely compatible. The only difference is that instead of saying "if (cmd == 45)", you will have to use the new CMD_IS macro. For example: if (CMD_IS("deposit")) { GET_GOLD(ch) += 1000; ... The new system is much easier to use, IMHO, and the code becomes much more readable. I will also be fixing the misaligned AFF_ bits as per Danny Baker's description; keep that in mind if you're writing areas. Well, that's all the sneak peeks for now. :) Jeremy PS - Danny Baker, if you're still out there, could you drop me a line?
This archive was generated by hypermail 2b30 : 12/07/00 PST