Well, I have a proposal for more aesthetically correct variable names. I personally use this system as much as possible, what has kept me from implementing it on CircleMUD is my lack of full knowledge of other systems (i.e, what systems this would break on and what the appropriate sizes are to fix it). My proposal is this: Where possible, change names such as: unsigned short signed short short unsigned long signed long long etc, to UInt16 SInt16 SInt16 UInt32 SInt32 SInt32 respectively. The reasoning behind this is it allows for easier instant recognition of sizes and type, and is in general faster to type (for some). As you can tell, the format is: [U|S]Int[#] Where [U|S] is U for unsigned, S for signed, and # is the # of bits of the variable. Therefore there would also be UInt8 and SInt8. I think some would like this system, I don't know about the rest. Responses? Flames? Comments? Kudos (bars)? - Chris Jacobson +------------------------------------------------------------+ | Ensure that you have read the CircleMUD Mailing List FAQ: | | http://democracy.queensu.ca/~fletcher/Circle/list-faq.html | +------------------------------------------------------------+
This archive was generated by hypermail 2b30 : 12/08/00 PST