> --- peter dahlgren <peter_dahlgren2002@YAHOO.SE> wrote: > > and another thing, if i want 6 classes in total, 1 first class [0], > > and 5 multi classes(additions)... should i have [5] or [6]? i don't > > know if the zero counts as a number here... "Shane P. Lee" wrote: > Yes, Zero counts, but the array value should always be one number > higher. What you should have is 'chclass[NUM_CLASSES ++]' which Um, what? I'm hoping you mean 'chclass[NUM_CLASSES + 1], because attempting to increment a constant does a whole lot of nothing (and results in a compilation error). > is more portable. On a side note, since 'class' is a reserved > keyword for C++, it's something that should be avoided. 'class', like all other tokens in C and C++ is unique from any combination of it and other characters. That is, 'chclass' is no more likely to collide with 'class' than 'rutabaga' and 'Class' are. Unless you think 'chClass' or 'ch_class' is a bit more readable, there's no reason to change this variable name. -- +---------------------------------------------------------------+ | FAQ: http://qsilver.queensu.ca/~fletchra/Circle/list-faq.html | | Archives: http://post.queensu.ca/listserv/wwwarch/circle.html | | Newbie List: http://groups.yahoo.com/group/circle-newbies/ | +---------------------------------------------------------------+
This archive was generated by hypermail 2b30 : 06/25/03 PDT