Hi, All! Piece of code from comm.c: void check_idle_passwords(void) { struct descriptor_data *d, *next_d; for (d = descriptor_list; d; d = next_d) { next_d = d->next; if (STATE(d) != CON_PASSWORD && STATE(d) != CON_GET_NAME) continue; ^^^ This way player will idle out only if he is currently at password or name prompt... Is there any reason to not add "CON_GET_SEX", "CON_GET_CLASS" and others to there? Andrey (andrey@alex-ua.com) aka Zmey//RMUD +------------------------------------------------------------+ | Ensure that you have read the CircleMUD Mailing List FAQ: | | http://democracy.queensu.ca/~fletcher/Circle/list-faq.html | +------------------------------------------------------------+
This archive was generated by hypermail 2b30 : 12/15/00 PST